Blog de guebs

Anuncios y novedades

Ruby 2.4 disponible en todos los servicios de hosting

Aitor Ortuondo — 19 de junio, 2017 @ 09:370 comentarios

3 Flares 3 Flares ×

Desde hace unos días ya es posible utilizar el nuevo stack Ruby-Fox en nuestros servicios de hosting, planes revendedor y servidores Cloud Premium.

Ruby fox

El stack Ruby-fox incorpora actualmente la versión 2.4.1 de Ruby y la 2.6.12 de Rubygems, las cuales iremos actualizando dentro de las mismas ramas: 2.4 en el caso de Ruby y 2.6 en el caso de Rubygems.

Ruby-fox es ahora el stack que os recomendamos utilizar, el cual es totalmente compatible con la versión más moderna de Ruby on Rails, la 5.1.

Para hacer uso de Ruby fox no tienes más que seleccionar esta versión a la hora de definir una nueva aplicación Ruby desde el apartado Aplicaciones Ruby del Panel de Hosting.

Definir aplicación Ruby Fox

Pero recuerda que no podrás hacerlo si en tu hosting ya tienes alguna aplicación Ruby. Si, por ejemplo, tienes una aplicación usando Ruby-Kon y quieres actualizar a Ruby-Fox, lo primero que debes hacer es eliminar la aplicación desde el apartado Aplicaciones Ruby e inmediatamente volver a añadir la misma aplicación usando el nuevo stack.

Hosting Ruby fácil y flexible

Unificar los conceptos fácil y flexible en un mismo servicio no es una tarea sencilla, pero es lo que aspiramos desde siempre. Durante años hemos ido mejorando nuestro servicio de hosting para Ruby: haciéndolo cada vez más potente, flexible y fácil de utilizar.

Actualmente, gracias a la estabilidad y rendimiento de nuestra plataforma de hosting, podemos alojar grandes aplicaciones Ruby on Rails, capaces de atender miles de usuarios diarios.

Y al mismo tiempo, gracias a que ofrecemos 6 stacks de Ruby diferentes y la posibilidad de instalar casi cualquier gema que puedas necesitar, nuestro servicio es extraordinariamente flexible, capaz de alojar prácticamente cualquier aplicación Ruby.

Actualmente, ofrecemos los siguientes stack:

  • Ruby Fox: Ruby 2.4 y Rubygems 2.6.x
  • Ruby Tux: Ruby 2.3 y Rubygems 2.6.x
  • Ruby Kon: Ruby 2.2 y Rubygems 2.4.x
  • Ruby Hay: Ruby 2.1 y Rubygems 2.2.x
  • Ruby Lur: Ruby 1.9 y Rubygems 1.8.x
  • Ruby Sua: Ruby 1.8.7 y Rubygems 1.5.x

Por último, pero no menos importante, gracias a la mejora de la interfaz y la disminución de pasos necesarios, el procedimiento de deployment de aplicaciones Rails es cada vez más fácil y rápido en nuestros servicios.

Eliminación del stack Ruby Ura

Además de añadir Ruby-fox hemos eliminado el stack Ruby-Ura. Este era nuestro stack más antiguo y obsoleto, el cual ofrecía Ruby 1.8.7 y Rubygems 1.3.5 .

Dado que era software obsoleto su eliminación se hacía cada vez más necesaria y su utilización por nuevos proyectos hacía mucho tiempo que no tenía sentido.

Lo cierto es que hacía tiempo que no alojabamos ninguna aplicación que usara Ruby-Ura, ya que en su día nos encargamos de adecuar todas las aplicaciones antiguas para que funcionaran con Ruby-Sua.

Cese de soporte para Rails 2.2 e inferiores

La eliminación del stack Ruby-Ura no es el único paso que hemos dado para asegurar que nuestra plataforma de hosting es capaz de aceptar futuras mejoras y actualizaciones. Hace aproximadamente 2 años anunciamos el cese de soporte para aplicaciones Rails 1 y en este ocasión tenemos que hacer lo mismo con Rails 2.2 e inferiores.

Llegar a esta situación no ha sido fácil ni rápido, dado que hasta hace poco alojabamos decenas de aplicaciones Rails 2.2 e inferiores. No solo actualiazamos decenas de aplicaciones a Rails 2.3.18, también tuvimos que buscar una solución para un conjunto de aplicaciones imposibles de actualizar.

El cese del soporte para Rails 2.2 e inferiores era un paso necesario para poder continuar mejorando nuestro servicio, pero no queríamos dejar sin servicio a nuestros clientes. Por ello, finalmente optamos por mover aquellas aplicaciones no actualizables a un servidor especial, independiente a nuestra plataforma de hosting.

En resumen, en adelante no podrás alojar nuevas aplicaciones que hagan uso de versiones de Ruby on Rails 2.2 e inferiores, es decir, Rails 2.3 será la versión más antigua que podrás hacer funcionar en nuestros servicios de hosting.

3 Flares Twitter 0 Facebook 0 Google+ 0 Buffer 3 LinkedIn 0 Email -- 3 Flares ×

Etiquetas:

Sobre el autor de este artículo

Aitor Ortuondo es fundador de guebs, donde se dedica a hacer un poco de todo: atender a los clientes, desarrollar nuevas funcionalidades, escribir en este blog, supervisar la infraestructura técnica, comprar el cafe, ...

De vez en cuando publica algo en Twitter y .

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Categorías

Etiquetas

.EUS concurso correo cpd Dominios guebs hosting logo marte mi@guebs NodeJS Nuevos gTLD passenger PHP rails Revendedor ruby Ruby on Rails Servidor Cloud Servidor Cloud Premium sh1 sh2 SH3 sh4 sh5 sh6 sh7 sh9 spam WordPress

Histórico

Sindicar

Puedes sindicar el contenido de este blog en tu lector de noticias usando alguna de las siguientes formas:

Ya es hora de disfrutar de un hosting de calidad

contrata ahora
España México Colombia Peru Ecuador Chile Europa Reino Unido Euskera
© Ekostat Informatica, S.L. - Aviso Legal
css.php
3 Flares Twitter 0 Facebook 0 Google+ 0 Buffer 3 LinkedIn 0 Email -- 3 Flares ×